Home > Flight Simulation, Flightsim, FSX, SP2, Technical > SP2 install fix

SP2 install fix

Monday, December 17th, 2007

Bob Arnson posts a fix to the “Microsoft Flight Simulator X Service Pack 2 requires the English version of Flight Simulator X.” error.

About these ads
  1. Lisa
    Friday, February 25th, 2011 at 7:28 pm

    I HAVE FIXED THIS ISSUE :)
    You have to right click on command prompt in accessories, Click Run as administrator,
    Then once in command prompt Run the fsx SP 2.msi File,
    This will now install due to command promt having the correct admin rights,
    Took me all day to get this working SOLVED :)

  2. Travis
    Thursday, February 27th, 2014 at 9:09 pm

    Thank you! I was working on this for hours, then I found this post!

  1. No trackbacks yet.
Comments are closed.
Follow

Get every new post delivered to your Inbox.

Join 200 other followers